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Introduction 

This User’s Manual describes the software and hardware features of the Time Machine II 

(TMII),a portable kit designed for programming SiTime field programmable (FP) oscillators. The 

Time Machine supports many SiTime oscillator parts, with special socket cards that can 

accommodate different package sizes. 

Important Notes 

• Refer to disclaimer section for terms and conditions governing the use TMII and devices 

programmed on TMII. 

• After programming, place samples into an antistatic bag clearly marked "Engineering 

Samples." 

• Samples can only be programmed using specific field programmable (FP) parts for a 

given oscillator family. Refer to http://www.sitime.com/fp-devices for more information 

on how to select and order FP parts. 

• Please contact your SiTime sales representative for large volume production orders. 

• The Time Machine II has not been tested for EMC compliance, EMI radiation 

susceptibility, or any temperature and humidity cycling. The recommended temperature 

range is 20°C to35°C. 

Package Contents 
Your Time Machine II package consists of the following items: 

1. SiTime Programmer (1 pcs) 

2. Socket cards: 

Time Machine II comes with three different socket cards. Each adapter board includes 

two or more sockets for connecting devices in different packages to the main unit for 

programming. It is possible to remove and insert devices in the socket while the board is 

connected to the SiTime Programmer  

3. USB Cable (1 pcs) 

4. Quick Start Guide (can also be found here - http://www.sitime.com/tm-um) 

5. Samples kit with several devices (enclosed device types may vary;please contact sales for 

additional units) 

6. Tweezers for handling small devices manually 
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Figure 1: Time Machine II base unit 

 

 
Figure 2: Time Machine socket card SiT6160DK. Supports 5.0mm x 3.2mm (6-pin) and 7.0mm x 5.0mm (6-pin) 

 

 
Figure 3: Time Machine socket card SiT6161DK. Supports 2.0mm x 1.6mm (4-pin) and 2.5mm x 2.0mm (4-pin) packages 

 

 
Figure 4: Time Machine socket card SiT6162DK. Supports G package (2.7mm x 2.4mm 4-pin) and 3.2mm x 2.5mm (4-

pin) packages 

 

 
Figure 5: Time Machine socket card SiT6163DK. Supports G package (2.7mm x 2.4mm 4 pin) and 3.2mm x 2.5mm (6 pin) 

packages 

 

 Pin1 location 

Part outline 

Arrow indicates Pin1 
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Figure 6: Time Machine socket card SiT6165DK. Supports S package (SOT23-5) and 3.2mm x 2.5mm (6 pin) packages 

 

Software Installation 
Go to web page (http://www.sitime.com/tm-sw) and download SiTime installer. Run 

downloaded installer and you will be brought to screen below. 

 

Press Install button right after Time Machine Software. 

 

Note:  

The Time Machine requires .NET Frameworkinstalled on your computer. Install .NET 

Framework before installing Time Machine Software. Green checkmark will appear if .NET 

Framework will be present on target PC or after installation completed. 
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Once installation is completed Time Machine Software version will be displayed. 

 

Software Installation from File 

If you do not have the installation USB Flash drive, you may download Time Machine 

software from the TMII product page on SiTime website. In this case, you should install it by 

double-clicking the setup file and following the on-screen installation instructions. 

Hardware Connection 

Connect the SiTime Programmer to your PC using the USB cable. The power light will be 

illuminated. 

The first time the SiTime Programmer is connected, the Windows Found New Hardware 

notification will appear. Please wait until driver installation is completed. 
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Driver Installation 

The first time the software is started the driver installation will be required. Time Machine 

software will install all required drivers automatically.  

 

The Windows Security notification window will appear. Please check Always trust software 

from “sitime corp” and press the Install button. 
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Working With the Time Machine Software 

Starting the software launches the main user interface (UI) as shown in below. 

 

 

User Interface features 

The following features are available in the main UI: 

• TimeMachine> View Logs – launches the log viewer  

• TimeMachine>Auto Detect – enables/disables parts auto detection mode 

• TimeMachine> Settings  – launches available part families configuration 

• TimeMachine>Exit – quits the software 

• Help>View Manual – opens this User's Manual 

• Help>Supported devises – shows the list of devices supported by Time Machine  

Additional options 

Device status Operation indicator 

General software help 

Tracking ID field 

Part Number Generator button Datasheet button Program button 

Part Number field 

Message window 

Channel 1  

Channel 2 
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• Help > Register– links to registration on SiTime Corp. website (www.sitime.com/time-

machine-registration) 

• Help > FP Device Refill – links to Field Programmable Oscillators page 

(www.sitime.com/fp-devices) 

• Help>Get Support – opens your email client with a draft of support request e-mail 

• Help > Check for Updates – checks for software updates (requires internet 

connection) 

• Help > About - SW/FW versions , only SW version is shown if the SiTime Programmer 

is not connected 

• Device status – shows status of the SiTime Programmer (Connected/Disconnected) 

• Operation indicator – indicates operation status and results (READY/BUSY/PASS/FAIL) 

• Message Window – reflects operation result and part detection result. 

 

The main UI can run with or without the SiTime Programmer connected to the host computer. 

This allows you to view the programming log history and get software updates without 

connecting the base unit. 
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Entering Part Number 

You may type the SiTime Part Number into the Part Number Field or copy it from another 

source and paste. 

 

If you enter a valid SiTime Part Number, the background of the Part Number Field becomes 

green. The background will turn red when the part number is invalid. You cannot program the 

device with an invalid part number. 

 

 

(*) Time Machine II software will alert you with this icon if the part you are trying to 

program contains non-default drive strength. 

(**) With the correct part number in the Part Number Field Time Machine II software 

will automatically detect which FP (Field programmable or “blank”) family  you are going to use 

to program that part number. If you put a pointer over FP icon a box  with blank part number 

will appear. More details on FP parts may be found here. 
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Part Number Generator 

The Part Number Generator provides an option for generating SiTime part numbers. Click 

the Part Number Generator button on the appropriate Channel. Note that you should have a 

valid FP part in the specific Channel socket you are entering the part number in. The PN 

generator window will appear. 

 

Select the desired part family from the drop down list at the top of the Part Number 

Generator window. Specify desired frequency and other configuration parameters and click OK. 

The generated part number will be automatically pasted into the Part Number field of the 

appropriate Channel. The Cancel button returns you to the Channel view without updating the 

Part Number field. 
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Part Programming 

Once you have entered a valid part number, click the Program button to program the part. 

The programming process result will be reflected in the output window as shown below. 

 

If part programming is successful the Operation indicator field will show a green PASSED 

indicator. If the part programming fails the Operation indicator field will show a red FAILED 

indicator. In this case, see the"Programming generates a FAIL message"section of this manual 

for information about how to proceed. Part Verification is done automatically following any 

Programming operation. 

During Programming and Verification procedures the active channel window will dim and all 

controls in the channel dialog boxes will be disabled. The Operation indicator will read BUSY as 

shown below. 

 

Tracking ID 

The main UI includes an optional Tracking ID field to help you track programming history. 

After entering the part number but before programming, you may enter a text string to be 

associated with the part. This Tracking ID will then be displayed after programming in the Logs 

viewer window. 

Auto Detect Mode 

To enable Auto Detect mode click TimeMachine > Auto Detect. The check mark will be 

displayed indicating that Auto Detect mode is enabled. In Auto Detect mode with the SiTime 

programmer connected, the software will automatically check for the presence of a part in each 
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Channel and bring up an individual channel view for the appropriate channel. An appropriate 

message will be displayed in the Message Window whenever an FP part is detected. 

Auto Detect mode can be used for part frequency estimation. If an already programmed 

part is inserted in the socket, the message will display the estimated part frequency. 

 

 

Viewing Operation Logs 

Time Machine stores records of all parts programmed and you can access them at any time 

in order to view programming history. In order to launch the Log Viewer please select 

TimeMachine > View Logs on the main UI.  

Note:  

Auto Detect estimated frequency measurement result should not be used for part 

performance judgment. 
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Data Log Mode 

Data log mode allows storing additional information about programmed parts and order 

during batch programming. To switch to the data log mode please select View > Data Log as 

shown in the figure below.  

 

Data Log Utility has fields for entering ordering information, operator lot information and 

part number. Fields marked with red asterisk should be filled mandatory. Once required 

information is entered, it’s possible to start programming session.  

 

At the beginning of programming session Part Number Generator appears showing decoded 

Device status 

Sessionstart button Operator’sname 

Quantityof parts to be 

programmed 

Lot ID 

Operation selection 

Channel selection 

Sample request number 

Part number field 

Customer FP part number 

Message window 

Operation indicator 

Mean part programming 

time 

 
Session start time 

Session end time 

Session yield 

Quantity of processed parts 

(programmed + failed) 
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part number. After pressing OK in Part Number Generator window programming of first part 

starts. When part programming is done operator should place new FP part and press 

Program Next button. Programming session ends when number of programmed parts reaches 

Actual Quantity entered or Stop button is pressed. At programming session end programming 

information is stored to the log.  

 

Viewing Data Logs 

Data logs can be displayed by opening Log Viewer (TimeMachine > View Logs) and selecting 

Data Log tab.  
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Firmware Updates 

The Time Machine may require a firmware update. You will be prompted to apply it during 

the software launch or when you connect the device. 

 

It is strongly recommended that you perform an update immediately.  

Do not close the application until the update process is complete. The FW update process will 

start after clicking OK.  

 

 

Note:  

Windows Found New Hardware notification may appear during the firmware update. In this 

case, please wait until driver installation is complete. 
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Software Updates 

The software will occasionally check for availability of a new software version. This feature 

requires an internet connection. You can check for updates manually at any time by clicking 

Help >Check for Updates under the menu in Time Machine software. 

 

If a software update is available, press Yes to download the update. The installation will start 

automatically after finishing download process. You will also be notified if your Time Machine 

software is up-to-date. 
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Troubleshooting 

Several common issues may occur while using Time Machine. This section describes how to 

address them. 

The Time Machine fails to start 

Reinstall the Time Machine software. Run TimeMachineSetup.msi from the USB Flash drive 

or download from the SiTime site: TMII product page or request the Time Machine software via 

email from your local SiTime sales representative. 

Programming generates a FAIL message 

Make sure you are using an appropriate Field Programmable (FP) part in the correct socket 

and that part has not been programmed already. If these conditions are met and programming 

fails, try replacing the device. 

Reporting a bug 

Time Machine has an automatic crash report sending feature. If the system crashes, please 

send a report to SiTime. Please provide additional information to help us to analyze and resolve 

the issue. 

 

If you find a bug that does not cause the program to crash, or if you have a feature to 

suggest, please contact SiTime Support at TimeMachineSupport@sitime.com. Please follow 

suggestions in this section before reporting an issue. 
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Disclaimer 

1. The Time Machine II Programmer and associated hardware (henceforth Platform) are 

intended for use only with SiTime's MEMS oscillators. This Platform will not program any 

other manufacturer's programmable oscillators and no attempt to do so should be 

made. 

2. The Platform is intended for use for engineering development and evaluation of SiTime's 

MEMS Oscillators. SiTime does not guarantee or warranty the devices that are 

programmed on this Platform for qualification or production purposes. 

3. The Platform should be used in static free environment with good engineering practices. 

4. This Platform does not fall under the scope of the European Union directives regarding 

electromagnetic compatibly, FCC, CE or UL and therefore may not meet the technical 

requirements of these directives. 

5. THE PLATFORM AND ITS ACCOMPANYING SOFTWARE AND DOCUMENTATION ARE 

PROVIDED ON AN "AS-IS" BASIS, "WITH ALL FAULTS", AND WITH NO WARRANTY 

WHATSOEVER.  SITIME AND ITS LICENSORS EXPRESSLY DISCLAIMS ALL WARRANTIES, 

WHETHER EXPRESS, IMPLIED OR STATUTORY, INCLUDING WITHOUT LIMITATION ANY 

WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, TITLE, AND 

NON-INFRINGEMENT.  SITIME DOES NOT WARRANT THAT USE OF THE PLATFORM (OR 

ITS ACCOMPANYING SOFTWARE) WILL BE UNINTERRUPTED OR ERROR-FREE OR THAT 

DEFECTS WILL BE CORRECTED OR THAT THE PLATFORM (OR ITS ACCOMPANYING 

SOFTWARE) ARE FREE OF VIRUSES OR OTHER HARMFUL COMPONENTS. 

6. The user assumes all responsibility and liability for [the] proper and safe handling of the 

Platform and the associated programmed MEMS Oscillators. 

7. The user indemnifies SiTime from all claims arising from the handling or use of this 

Platform and the associated field programmable devices. 

8. Please contact a SiTime representative if you have any issues or problems with using this 

Platform. 


